Invalid Swift Support when deploy to Apple Store

Snaml Book / Card is a 2D Web Organizer, a 4-Way Web Navigator, and a Fullscreen Web Browser.

Invalid Swift Support when deploy to Apple Store

Postby adputer on Sun Sep 20, 2015 9:54 pm

Error message when upload to Apple Store

Invalid Swift Support The files libswiftCoreLocation.dylib, libswiftCoreMedia.dylib, libswiftCoreData.dylib, libswiftAVFoundation.dylib ...

To resolve this following Apple's message and do

1. Archive app with new build number
2. Find the archive (.xcarchive file) in Finder from Organizer right mouse click “Show in Finder”
3. Open the package by show content and find directories like Products/Applications/YourApp.ipa/Frameworks/ and SwiftSupport/iphoneos/
4. Copy all libswiftXxx.dylib files from SwiftSupport/iphoneos/ into Products/Applications/YourApp.ipa/Frameworks/ and overwrite
5. Note YourApp.ipa is a package so need to show content to open the folder
6. Upload to App Store from Organizer
adputer
Site Admin
 
Posts: 261
Joined: Thu Jan 10, 2008 3:12 pm
Location: Ontario, Canada

Return to Snaml Book / Card

Who is online

Users browsing this forum: No registered users and 0 guests

cron